source: libs/SAMGAR V2/Module/CMakeLists.txt @ 652

Revision 652, 780 bytes checked in by KDucasse, 9 years ago (diff)
Line 
1# YARP needs CMake 2.6 or greater
2cmake_minimum_required(VERSION 2.6)
3
4# find YARP
5find_package(YARP REQUIRED)
6
7# find OpenCV
8find_package(OpenCV REQUIRED)
9
10# add YARP include directories
11include_directories(${YARP_INCLUDE_DIRS})
12include_directories(${OpenCV_INCLUDE_DIRS})
13
14
15# create samgar module library
16add_library(SamModule SamClass.cpp)
17
18# set up our program
19add_executable(SamExamples SamExample.cpp ExampleOne.cpp)
20add_executable(VideoSend VideoSend.cpp)
21add_executable(VideoGet  VideoGet.cpp)
22
23# link with YARP libraries
24target_link_libraries(SamExamples SamModule ${YARP_LIBRARIES})
25target_link_libraries(VideoSend SamModule ${YARP_LIBRARIES} ${OpenCV_LIBRARIES})
26target_link_libraries(VideoGet SamModule ${YARP_LIBRARIES} ${OpenCV_LIBRARIES})
Note: See TracBrowser for help on using the repository browser.